iOS 4.2.1 Jailbreak für iPhone 4, iPod touch erschienen, Unlock angekündigt

| 12:43 Uhr | 27 Kommentare

redsnow096b4
Kaum hat Apple die finale Version von iOS 4.2.1 für das iPhone, iPad und den iPod touch veröffentlicht, lässt sich auch das iPhone Dev Team nicht lumpen und veröffentlicht mit redwn0w 0.9.6b4 einen iOS 4.2.1 Jailbreak. Vorab folgender Hinweis: User, die ihr iPhone mittels Unlock bearbeitet haben, sollten die Finger von der neuen Firmware lassen. Für Besitzer älterer Geräte (iPhone 3G, ältere iPhone 3GS und non-MC iPod touch 2G) ändert sich nichts. Der Jailbreak funktioniert mit redsn0w wie eh und je. Das Jailbreak Tool bietet einen untethered iOS 4.2.1 Jailbreak. Nutzer neuerer Apple iOS Geräte (z.b. iPhone 4, iPod touch 4G, iPad) können ihr Gerät mit dem Tool bereits öffnen, erhalten aber nur einen tethered Jailbreak. Dieser geht bei jedem Neustart des iDevices verloren. Es dauert noch ein paar Tage bis Comex einen passenden untethered Jailbreak präsentiert. Redsn0w 0.9.6b4 steht sowohl für Mac OS X und Windows zur verfügung.

Und auch in Sachen iOS 4.2.1 Unlock meldet sich das iPhone Dev Team zu Wort. So wollen die Hacker bereits diese Woche einen iOS 4.2.1 Unlock für das iPhone 3G und iPhone 3GS bereit stellen. Ein Unlock für das iPhone 4 (iOS 4.2.1) scheint aufwendiger und soll nachgereicht werden. (via iPhone Dev Team)

Update 27.11.2010: Aufgrund der vielen Nachfragen hier noch eine Ergänzung zum oben beschrieben iOS 4.2.1 Jailbreak. Nachdem ihr euer Gerät (hier sind alle neueren iDevices wie z.B. das iPad, iPhone 4, iPod touch 4G und Co. gemeint, zum ersten Mal mit dem tethered Jailbreak versehen habt bzw. das iDevice neu gestartet habt, müsst ihr dieses erneut über redsn0w „freischalten“. Dazu startet ihr redsnow, wählt die passende Firmware und wählt im nächsten Schritt „Just boot tethered right now“ und folgt den Anweisungen für den DFÜ Modus. Erst kann habt ihr bzw. habt ihr wieder Zugriff auf den Jailbreak und Cydia. Diese Prozedur ist zwar ein wenig lästig, aber anders ist der Jailbreak derzeit auf den neuen Geräten nicht durchführbar. Wie bereits erwähnt, arbeitet Comex an einem untethered Jailbreak für iOS 4.2.1.

27 Kommentare

  • Katchau

    Also kann ich als 3G besitzer, ohne weiters updaten und jailbreaken…. oder sollte ich noch ein wenig warten da ich auf ein unlock angewiesen bin ?

    23. Nov 2010 | 12:57 Uhr | Kommentieren
  • efrin1984

    Das ist ein supper Sache!

    23. Nov 2010 | 13:06 Uhr | Kommentieren
  • MAikIan

    Ist er nun untethered oder nicht

    Andere Seiten schreiben das er tethered ist.habe zur Zeit 4.1 mit limärain jailbreak??????

    23. Nov 2010 | 13:09 Uhr | Kommentieren
  • Micha

    @ Katchau
    Steht doch da: nicht updaten, falls Du auf den Unlock angewiesen bist.

    @ MAikIan
    Steht doch auch im Artikel: untethered für altere Modelle und für neuere iDevices tethered

    23. Nov 2010 | 13:13 Uhr | Kommentieren
  • Kevin

    Und wann kommt endlich der Unlock für das Iphone 4 mit dem Bassband 02.10.04?Es hat doch geheissen das ein unlock für das Iphone 4 mit dem Bassband 02.10.04 auch gleich nach 4.2 rauskommt.

    23. Nov 2010 | 13:16 Uhr | Kommentieren
  • MAikIan

    Oh micha

    Sorry hab ich wohl zu schnell überflogen.
    Das heißt dann wohl noch warten . iPhone ist mir eigentlich egal, keine Funktionen die ich brauch. Aber mein iPad schreit danach.

    23. Nov 2010 | 13:20 Uhr | Kommentieren
  • Curtiz

    Okay meine Frage ->
    Welche Rolle spielt es was für ein baseband ich in meinem handy habe (iphon4)?

    23. Nov 2010 | 13:49 Uhr | Kommentieren
  • Sina

    @curtiz

    Manche Basbandversionen können noch nicht geunlocked werden

    23. Nov 2010 | 13:54 Uhr | Kommentieren
  • Curtiz

    Ok das wichtig weil ich meins unlocken will. Ich weiß das es bis zum Unlock für i4 noch etwas zeit braucht. Aber wie check ich ob das mit meinem geht oder nicht? Ich date (sobald möglich) auf ios 4.2 auf, mach den jailbreak und unlocke. Denn jetzt hab ich grad noch ios 4.0 und „modem-firmware“ (das doch das baseband?!) 01.59.00.

    23. Nov 2010 | 14:06 Uhr | Kommentieren
  • Josh

    Ich habe zur Zeit auf meinem iPhone 4 die 4.1 mit einem limera1n Jailbreak.
    Hoffe das bald ein untethered Jailbreak folgt

    23. Nov 2010 | 15:17 Uhr | Kommentieren
  • Curtiz

    / I NEED ANSWERS /

    23. Nov 2010 | 17:15 Uhr | Kommentieren
  • Josh

    das baseband ist die version deiner mobilfunkbetreiber konfiguration.
    die wird mit softwareupdates aktualisiert, so muss eben auch redsn0w (also die software aus cydia zu unlocken) sich „anpassen“.

    23. Nov 2010 | 17:34 Uhr | Kommentieren
  • Sandra

    wann kommt endlich der Unlock für das Iphone 4 mit dem Bassband 02.10.04?Weis das jemand?Mfg

    24. Nov 2010 | 13:30 Uhr | Kommentieren
  • matzge

    wie siehts mit der 2 Generation(jaaa ich weis konnt mir nix neueres leisten=( ) aus is es möglich die neue softwere zu installieren?ß

    27. Nov 2010 | 18:58 Uhr | Kommentieren
  • Koopa09

    @#14 matzge

    Lass lieber die Finger davon, wird nur hacken… Als wenn du windows vista auf nem 1980 PC packst.,.. Sogar bei dem 3g spackt 4.1 …
    Also lass besser

    29. Nov 2010 | 10:45 Uhr | Kommentieren
  • Koopa09

    Lass lieber die Finger davon, wird nur hacken… Als wenn du windows vista auf nem 1980 PC packst.,.. Sogar bei dem 3g spackt 4.1 …
    Also lass besser

    29. Nov 2010 | 10:46 Uhr | Kommentieren
  • **E***

    Hallo
    eine frage wenn ich jetzt dann BB 06.15.00 auf meinem 3G habe kann ich dann auch wieder i-wann ein originales drauf spielen ?

    LG Danke

    29. Nov 2010 | 21:21 Uhr | Kommentieren
  • Nando

    Hilfe! Ich hab ein iPod Touch 2G der af 4.2.1 geüpdatet wurde und wenn ich das tool blacksnow benutze dann steht da immer dieser ein error
    Ich fange langsam an zu verzweifeln!
    Gibt es vielleicht noch eine andere möglichkeit den Jailbreak durchzuführen? Ich brauch ja nur cydia. Bitte um Hilfe!

    30. Nov 2010 | 0:01 Uhr | Kommentieren
  • Nando

    Sorry ich meinte Redsn0w 🙂

    30. Nov 2010 | 0:03 Uhr | Kommentieren
  • Halil

    Wann kommt das jailbreak 4.2.1 für das i phone 4 raus bitte helfen wäre echt nett.

    01. Dez 2010 | 20:49 Uhr | Kommentieren
  • Woehry

    Ist schon längst draußen. Wer lesen kann ist klar im Vorteil, steht im ersten Satz des Berichts.

    02. Dez 2010 | 14:05 Uhr | Kommentieren
  • icrak

    Hallo

    Wieso steht da das es auch für MC model geht

    Bei meinem ipod touch 2G MC geht es nicht na toll

    Danke für die Verarsche

    06. Dez 2010 | 4:51 Uhr | Kommentieren
  • Woehry

    Wieso steht da das es auch für MC model geht

    Da steht „non-MC“!!! Non bedeutet nicht. Also für alle nicht MC-Modelle iPod Touch funktioniert der Jailbreak.

    06. Dez 2010 | 10:23 Uhr | Kommentieren
  • Woehry

    Da steht „non-MC“!!! Non bedeutet nicht. Also für alle nicht MC-Modelle iPod Touch funktioniert der Jailbreak.

    06. Dez 2010 | 10:24 Uhr | Kommentieren
  • Torsten

    wenn man das falsche baseband hat oder aus sucht zerschiest ihr euer GPS(evtl.für immer) !!!! nur ein rücksetzen der firmware auf 3.1.3 kann evtl.wieder zum laufen bringen Betroffene Geräte Iphone einschlisslich alle!!! auch ipod 4.sowie Ipad 3G.von 11 Getesteten Geräten 2 wieder GPS haben 9 darunter iphone4 sowie 3GS kein GPS empfang mehr Möglich!!!!

    28. Dez 2010 | 12:20 Uhr | Kommentieren
  • Carl

    Was laberst du für ein gedöns das baseband hat nix mit em GPS zu tun!

    04. Apr 2011 | 14:49 Uhr | Kommentieren
  • Fleetakz

    Ich habe das iphone4 mit 4.2.1 ..giebt es schon einen slide jailbreak für das iphone4?

    06. Okt 2011 | 14:46 Uhr | Kommentieren

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.